Follow Me Icons

 

Follow @KendrickColeman on TwitterConnect on LinkedInWatch My Videos on YouTubeFollow me on FacebookCheck Out My Projects on GitHubStay Up To Date with RSS

Search

BSA 728x90 Center Banner

Need some help getting a 3COM 4500 trunk to Cisco 3750G

*Updated 8/27/2009* Partially Solved

I've searched the web and can't get an explanation as to why this isn't working. Currently everything (switch IP addresses, users, servers, etc) are all on the defualt Vlan (That's the way it was setup before I got here and I don't like messing with 3Com switches so I haven't had time to take them off the default Vlan). My goal is to setup Vlan 2 as the management Vlan for all network equipment and eventually get everything off the default vlan.

I am trying to get a trunk setup between a Cisco 3750G and 3Com 4500 SuperStack3. This is just a test for right now because the 3Com that is in production is a 3Com 4200G.

 Here is the setup. For easy reference I've made:

  • A = PC on Vlan 2
  • B = 3Com 4500 Layer 2 switch
  • C = Cisco 3750G Layer 3 switch
  • D = PC on Vlan 1

 

On the 3750G I have tried these configs

interface Gi1/0/5
switchport trunk encap dot1q
switchport mode trunk

Also Tried...

interface Gi1/0/5
switchport trunk encap dot1q
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allow vlan 1,2
switchport nonegotiate

On the 3com I have gone through the WebGUI (because i don't know 3Com CLI stuff) and done the following
Device -> Vlan Interface -> Create -> Vlan ID = 2, Manual IP = 192.168.2.30
Device -> Vlan -> Create Vlan 2
Port -> Administration -> Setup -> Click on Port 5, change the Link Type to "Trunk" -> Hit Apply
Port -> Vlan -> Modify Port -> Port 5 now says "Not Available for selection", hit the "Tagged" radio button, click on Port 5, Click all VLANs -> Hit Apply

Now if I go to Device -> Vlan -> Port Detail -> Click on Port 5 it shows "Untagged member of VLAN(s)" =1, "Tagged member of VLAN(s) =2-4094

So in my mind everything should be setup correctly on both ends, but the results show as if it's just an access port and not a trunk.

I've tried different variations of it all and i always end up with the same results:
From the 3750G (C) console, I can ping the 3Com 4500 (B)
From the 3750G (C) console, I can ping PC A
PC A can ping the 3COM 4500 (B)
PC A can ping both Vlan IPs on the the 3750G (C)
PC A CANNOT ping PC D
PC D can ping both Vlan IP addresses on the 3750G (C)
PC D CANNOT ping the 3Com 4500 (B)
PC D CANNOT ping PC A

 any and all help is very appreciated and the correct answer will be given credit on this blog entry.

 **Updated 8/27/2009**

Thanks to my fellow twitter friend @juicelsu009 I have the intervlan routing problem solved

this is a brand new, out of the box 3750G. I guess I got to far ahead of myself and forgot the one simple rule when configuring anything with Layer 3. 'ip routing'

as soon as i put in that command, PC A can ping PC D, and vice versa.

Now the only problem is that PC D cannot ping the 3Com4500 (B).
I believe this is an ACL problem because it won't connect or ping if it's on a different VLAN, even if PC A is put on a different Vlan on the switch.

I've tried setting up an ACL in the 4500 saying
permit 192.168.2.1 0.0.0.255
permit 192.168.3.1 0.0.0.255
and it's still not letting me ping or connect to it.



If I add a VLAN interface for Vlan 1 (ie 192.168.3.30) on the 4500, then I can ping the 4500 on both Vlans.

Not to sure what's going on, but I want to set the switch up to be accessible from any internal ip address, 192.168.0.0/16, but only have one Vlan interface IP address. So if you know anything about 3Com switches, any help is appreciated. Thanks!!

 **Update 8/27/2009 1:11pm**

after much research I have found out that you MUST have the default Vlan be the management ip address of the switch. not cool 3Com, not cool. So much for integrating a management Vlan for all network equipment.

Related Items